Aw: Seite startet und springt nach wenigen Sekunden

  • image4you
  • Autor
  • Offline
  • Neues Mitglied
  • Neues Mitglied
Mehr
26 Mai 2011 17:45 #29222 von image4you
Liebe Freunde ich bin am Verzweifeln. Ich bastle nun seit Monaten an einem Problem, das warscheinlich lächerliche Ursachen hat, die ich aber nicht finde:

Hier gibt es Seiten - z.B. PRESSE die ganz kurz aufgebaut werden und dann springt der Browser in eine leere Seite. Woran bitte liegt das?

Gern schalte ich auch einen Profi kurz als Admin frei im Joomla, wenn das die Fragestellung einfach lösen hilft.

Hier die Details zum Joomla:

PHP erstellt für: Linux lvps83-169-44-52.dedicated.hosteurope.de 2.6.18-028stab070.14 #1 SMP Thu Nov 18 16:04:02 MSK 2010 x86_64
Datenbankversion: 5.0.51a-3ubuntu5.8
Datenbankzeichensatz: utf8_general_ci
PHP-Version: 5.2.4-2ubuntu5.12
Webserver: Apache/2.2.8 (Ubuntu) mod_jk/1.2.25 mod_python/3.3.1 Python/2.5.2 PHP/5.2.4-2ubuntu5.12 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8
PHP-Anbindung zum Webserver: apache2handler
Joomla!-Version: Joomla! 1.5.22 Stable [ senu takaa ama woi ] 04-November-2010 18:00 GMT
Browserkennung: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

Safe-Mode: Aus
Open-basedir: /var/www/vhosts/sustainable-success.net/httpdocs:/tmp
Fehler anzeigen: An
Kurze Open-Tags: An
Datei-Uploads: An
Magic-Quotes: An
Register-Globals: Aus
Ausgabe puffern: Aus
Session-Speicherpfad: /var/lib/php5
Session-Autostart: 0
XML aktiviert: Ja
Zlib aktiviert: Ja
Deaktivierte Funktionen: Keine
Mbstring aktiviert: Ja
Iconv verfügbar: Ja
WYSIWYG-Editor: Editor - Kein Editor

$offline '0'
$editor 'none'
$list_limit '20'
$helpurl ' hilfe.jgerman.de '
$debug '0'
$debug_lang '0'
$sef '0'
$sef_rewrite '0'
$sef_suffix '0'
$feed_limit '10'
$feed_email 'site'
$secret 'HNxSzWDzUBkKFV31'
$gzip '1'
$error_reporting '-1'
$xmlrpc_server '1'
$log_path '/var/www/vhosts/sustainable-success.net/httpdocs/logs'
$tmp_path '/var/www/vhosts/sustainable-success.net/httpdocs/tmp'
$live_site ''
$force_ssl '0'
$offset '1'
$caching '0'
$cachetime '15'
$cache_handler 'file'
$memcache_settings array()
$ftp_enable '0'
$ftp_host '127.0.0.1'
$ftp_port '21'
$ftp_user 'xxxxxx'
$ftp_pass 'xxxxxx'
$ftp_root ''
$db 'xxxxxx'
$host 'xxxxxx'
$user 'xxxxxx'
$db 'xxxxxx'
$db 'xxxxxx'
$mailer 'mail'
$mailfrom 'ck@sustainable-success.ch'
$fromname 'Claude Keller - Sustainable Success'
$sendmail '/usr/sbin/sendmail'
$smtpauth '0'
$smtpsecure 'none'
$smtpport '25'
$smtpuser 'xxxxxx'
$smtppass 'xxxxxx'
$smtphost 'localhost'
$MetaAuthor '1'
$MetaTitle '1'
$lifetime '15'
$session_handler 'database'
$password 'xxxxxx'
$sitename 'Claude Keller'
$MetaDesc 'Claude Keller \'66, Executive und Business Coaching, kommt aus Schwyz und wollte als Kind Clown oder Astronaut werden. Seit 2004 ist er selbständig und arbeitet als Coach für Führungspersönlichkeiten.'
$MetaKeys 'claude,keller,coaching,business,coaching,führungscoaching,leadership,leadership,coaching,unternehmenskultur,kulturveränderung,neuroleadership,wertebasierte,führung,authentische,führung,burnout,outplacement,handlungsoptionen,entscheidungsfindung,emotionale,lösungen,raucherentwöhnung,motivation,erfolg,bewusstsein,ziele,erreichen,blockaden,lösen,sehmsdorf,raneri,image4you.net,oliver'
$offline_message 'claude,keller,coaching,business,coaching,führungscoaching,leadership,leadership,coaching,unternehmenskultur,kulturveränderung,neuroleadership,wertebasierte,führung,authentische,führung,burnout,outplacement,handlungsoptionen,entscheidungsfindung,emotionale,lösungen,raucherentwöhnung,motivation,erfolg,bewusstsein,ziele,erreichen,blockaden,lösen,sehmsdorf,raneri,image4you.net,oliver'

administrator/backups/ Beschreibbar
administrator/components/ Beschreibbar
administrator/language/ Beschreibbar
administrator/language/de-DE/ Beschreibbar
administrator/language/en-GB/ Beschreibbar
administrator/modules/ Beschreibbar
administrator/templates/ Beschreibbar
components/ Beschreibbar
images/ Beschreibbar
images/banners/ Beschreibbar
images/stories/ Beschreibbar
language/ Beschreibbar
language/de-DE/ Beschreibbar
language/en-GB/ Beschreibbar
language/pdf_fonts/ Beschreibbar
media/ Beschreibbar
modules/ Beschreibbar
plugins/ Beschreibbar
plugins/content/ Beschreibbar
plugins/editors/ Beschreibbar
plugins/editors-xtd/ Beschreibbar
plugins/search/ Beschreibbar
plugins/system/ Beschreibbar
plugins/user/ Beschreibbar
plugins/xmlrpc/ Beschreibbar
templates/ Beschreibbar
Cache-Verzeichnis /var/www/vhosts/sustainable-success.net/httpdocs/cache/ Beschreibbar
Cache-Verzeichnis /var/www/vhosts/sustainable-success.net/httpdocs/administrator/cache/ Beschreibbar
Log-Verzeichnis ($log_path) /var/www/vhosts/sustainable-success.net/httpdocs/logs/ Beschreibbar
Temp-Verzeichnis ($tmp_path) /var/www/vhosts/sustainable-success.net/httpdocs/tmp/ Beschreibbar

PHP Version 5.2.4-2ubuntu5.12

System Linux lvps83-169-44-52.dedicated.hosteurope.de 2.6.18-028stab070.14 #1 SMP Thu Nov 18 16:04:02 MSK 2010 x86_64
Build Date Sep 20 2010 13:16:35
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php5/apache2
Loaded Configuration File /etc/php5/apache2/php.ini
Scan this dir for additional .ini files /etc/php5/apache2/conf.d
additional .ini files parsed /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/ioncube-loader.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/xsl.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety disabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams zip, php, file, data, http, ftp, compress.bzip2, compress.zlib, https, ftps
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, bzip2.*, zlib.*

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
26 Mai 2011 19:07 #29223 von jimbo
Ich kann das Problem nicht nachvollziehen (Mac OS X mit Safari / Firefox). Im FF ist alles normal, im Safari "flackert" die Seite kurz, wird dann aber ebenfalls korrekt angezeigt. Ich würde tippen dass das an einem der eingebauten Javascripts liegt...

Gruss Dany (Jimbo)
Kein Support per PN.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
26 Mai 2011 19:26 #29224 von uscher2
also ich kann nichts finden. habe ein bisschen rumgeklickt auf deiner seite und alle seiten bauen sich normal auf - springen nicht auf eine leere seite.

abgesehen davon sollte dieser Beitrag verschoben werden zu JOOMLA 1.5, hier bist du bei 1.6 gelandet.

Gestern noch zu blöd, den Computer einzuschalten,
heute schon die eigene Homepage

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
26 Mai 2011 21:55 #29225 von Tribal6
Hossa

Beim mir (Windows) im IE 8 und Safari ok, aber im FF (3er Reihe) hab ich ab und zu wie beschrieben eine weisse Seite. Die Serverheader sind 200 OK.

Da JavaScript je nach Browser (und OS) z.T. unterschiedlich interpretiert werden, würd ich mal sagen, es liegt am JavaScript, rsp. zwei JavaScripts kollidieren miteindander, je nach Konstellation von OS und Browser (inkl.Version).

Du hast bei dir ja der Klassiker schlechthin für mögliche Fehler: Mootools vom System und jQuery vom mod_gtranslate. Wenn diese beiden zusammen verwendet werden (und jQuery normal, ohne den noConflict-"Modus" läuft). Könnte aber auch am 'AC_Run_Active_Content.js' oder 'ffont.js' im Template liegen. Mal das eine oder andere ausschalten, um die Fehlerquelle einzukreisen

- mod_gtranslate ein/ausschalten (jQuery)
- als Template mal kurz ein Standart wählen (ffont.js und AC_Run_Acitve_Content.js)

Jeweils vor dem Kontrollieren den Browser-Cache leeren, oder Neuladen ohne Cache (win/FF ctrl + F5), da JavaScripts z.T. vom Browser gechachet werden.

Ev. findest du ja so den Übeltäter ;)

Cheerio
Roger


Tue das was du kannst, mit dem was du hast, da wo du bist

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • image4you
  • Autor
  • Offline
  • Neues Mitglied
  • Neues Mitglied
Mehr
27 Mai 2011 14:25 #29232 von image4you
wow, ROGER - das könnte es wirklich sein, danke.

Replizieren kann ich den Fehler ambesten, wenn ich im Safari (MAC) oder im Nightly (FF 6) den CACHE leere und dann eine dieser Seiten aufmache.

Ich probiere das mal aus und melde mich wieder.

lG Oliver

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • image4you
  • Autor
  • Offline
  • Neues Mitglied
  • Neues Mitglied
Mehr
27 Mai 2011 14:41 #29234 von image4you
Schade, aber das Abschlaten löst das Problem nicht. "PRESSE" ist der Idealtest. Ich probiere mal die anderen Ideen aus.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
27 Mai 2011 19:21 #29236 von Tribal6
ok, neue Erkentnis, nächster Versuch:

1. Es kann daran liegen, dass bei dir 'noch' Mootools 1.12 läuft. Schalt mal im Backend das 'mootools upgrade'-Plugin ein, das upgradet das Mootools auf 1.2.4.

2. Du hast viele 'grosse' Bilder in diesem Beitrag eingebunden. Was die Seite insesamt langsamer macht. Das könnte in gewissen Browserversionen (anscheinend) das domReady-Event zu früh auslösen: JavaScript-Funktionen, die auf die vollständigkeit des kompletten HTML-Baums angewiesen sind, funktionieren so nicht richtig. Mal ein paar der Grafiken in dem Beitrag rausnehmen, und testen.

Und wieder melden ;)


Tue das was du kannst, mit dem was du hast, da wo du bist

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • image4you
  • Autor
  • Offline
  • Neues Mitglied
  • Neues Mitglied
Mehr
31 Mai 2011 14:09 #29275 von image4you
Hi Roger, hi Folks

Ich glaube der Tipp mit dem Resize der Bilder ist die Lösung.
Ich habe alle Bilder um 50% verkleinert (IMAGES - FTP, download, rezize, upload). Nun kann ich den Fehler nicht mehr replizieren.

Der erste Versuch mit dem Mootools update führte zum Einfrieren der Seite. Das habe ich wieder de-aktiviert.

Ganz herzlichen Dank.

lG Oliver

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
31 Mai 2011 14:35 #29276 von Tribal6
yupp, denke, das war's, bei mir nun auch im FF keine Fehler rsp. weisse Seite mehr.

Schliesslich war ja nur die Frage wann, und nicht ob wir das beheben können ;)

Cheers
Roger


Tue das was du kannst, mit dem was du hast, da wo du bist

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • image4you
  • Autor
  • Offline
  • Neues Mitglied
  • Neues Mitglied
Mehr
31 Mai 2011 14:40 #29277 von image4you
Ich schlage vor ein GELÖST in die Start-Frage zu füllen. Könnte anderen helfen, oder?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: Tribal6RePaoDragonlordChris Hoefligerpascaleadiheutschi.ch
Powered by Kunena Forum

Joomla! Verband Schweiz - Mitglied werden