Joomla! Forum Schweiz wird Teil der D-A-CH Community

Nach vielen Jahren als zentrale Anlaufstelle für Fragen rund um Joomla! in der Schweiz wird das Joomla! Forum Schweiz künftig als Archiv weitergeführt.

Die Joomla!-Communities aus Deutschland, Österreich und der Schweiz arbeiten heute enger denn je zusammen. Deshalb bündeln wir künftig auch den deutschsprachigen Support und Austausch an einem gemeinsamen Ort im Joomla! D-A-CH Forum.

Für neue Fragen, Diskussionen und den Austausch mit der Community nutzt bitte ab sofort:

forum.joomla.de

Das Joomla! Forum Schweiz bleibt weiterhin bestehen und wird als Archiv im Lesemodus erhalten. Die vielen Beiträge, Lösungen und Erfahrungen aus den vergangenen Jahren bleiben damit weiterhin zugänglich und über die Suche auffindbar.

Wir bedanken uns herzlich bei allen Mitgliedern, Moderatoren und Helfern, die das Schweizer Joomla! Forum über viele Jahre mit ihrem Wissen und ihrem Engagement geprägt haben.

Wir sehen uns im Joomla! D-A-CH Forum!

Keine Benutzeranmeldung möglich nach Patch von 1.5.6 auf 1.5.7

  • Wolf39
  • Autor
  • Neues Mitglied
  • Neues Mitglied
Mehr
25 Sep. 2008 19:57 #17170 von Wolf39
Nach dem ich meine Installation von der Version 1.5.6 auf die Version 1.5.7 durch einkopieren der Patchdatei geändert habe, kann sich kein Benutzer mehr anmelden. Es kommt die Fehlermeldung:
Fatal error: Call to undefined function: stripos() in /var/www/web1327/html/libraries/joomla/environment/uri.php on line 675

Die Anmeldung beim Aufruf der Seite ist ein einloggen als Administrator möglich. Alle anderen Funktionen funktionieren. Es lassen sich neue Benutzer einrichten, die Bestätigungs-mail kommt auch nur einloggen können sich auch die neu eingerichteten Benutzer nicht.
Ich würde mich sehr über freundliche Unterstützung bei der Fehlersuche freuen. Übrigens uf dem Server läuft PHP 4 u. 5! Daran sollte es nicht liegen. Die Version 1.5.6 lief ebenfalls problemlos,

Mit freundlichen Grüßen

Wolf39
  • SirDrake
  • Neues Mitglied
  • Neues Mitglied
Mehr
25 Sep. 2008 20:23 #17171 von SirDrake
Hi,
Zeile 675 in der Datei uri.php hiermit ersetzen
Code:
if(strpos($base,stristr($base,JURI::base())) !== 0 && !empty($host)) {
die Datei findest du unter libraries/joomla/environment

Gruß Friedel
  • Wolf39
  • Autor
  • Neues Mitglied
  • Neues Mitglied
Mehr
25 Sep. 2008 20:32 #17172 von Wolf39
Danke für den Hinweis, leider hilft das nicht ich habe schon versucht dort etwas zu finden woran es liegt und warum dieser Aufruf nicht verarbeitet werden kann.
Danke, dass Du hier reagiert hast.

Wolf39
  • RePao
  • Moderator
  • Moderator
Mehr
25 Sep. 2008 21:31 #17174 von RePao
Salü Wolf39,

was läuft da alles ausser Joomla!?
Wenn sonst nichts manipuliertes läuft würde ich nochmals versuchen die Aktualisierung darüber zu spielen. Ev. ging da was schief beim Upload..
  • Wolf39
  • Autor
  • Neues Mitglied
  • Neues Mitglied
Mehr
25 Sep. 2008 22:11 #17175 von Wolf39
Vielen Dank für den Hinweis, auch danach der gleiche Zustand. Interessant ist nur, das bei der gleichen Aktion auf meiner lokalen Installation dieser Fehler nicht auftritt.
Leider verstehe ich nicht sehr viel von PHP und da könnte man sicher den Fehler suchen.

Trotzdem vielen Dank.

Gruß, Wolf39
  • Wolf39
  • Autor
  • Neues Mitglied
  • Neues Mitglied
Mehr
25 Sep. 2008 22:40 #17177 von Wolf39
Hallloooooo, es geht wieder alles!
Was war die Lösung?
Alle haben etwas Recht gehabt. Das Austauschen der Zeile 675 war richtig, funktionierte aber erst nach dem 2. kopieren des Patches. Es waren offensichtlich 2 Ursachen, die das Treiben wild gemacht haben. Hat mich 4 Stunden Kopfzerbrechen gekostet nun aber der Erfolg mit Eurer Hilfe!!!
Ein großes Dankeschön und bis bald mit einem neuen Problem.

Gruß, Wolf39
  • balta
  • Neues Mitglied
  • Neues Mitglied
Mehr
04 Okt. 2008 16:46 #17409 von balta
Hallo Zusammen,

bin neu in dem Forum der Schweiz. Finde ich super das es einen gibt. Bin ein grosser Fahn von Joomla.
Das Problem hatte ich auch und nach dem ersetzten des Codes funktioniert es super.

Vielen Dank für die Lösung.

Gruss Igor
  • Michael-Zitrox
  • Neues Mitglied
  • Neues Mitglied
Mehr
04 Okt. 2008 17:49 #17412 von Michael-Zitrox
Im Joomla.org Forum habe ich irgendwo mal gelesen, dass es an einer alten PHP Version liegt..
Hoster mit php5 seien davon scheinbar nicht betroffen.
Mehr
04 Okt. 2008 18:00 #17413 von ghosty
Hi,

Ich denke das Problem hat auch hiermit zu tun:
--ALTER LINK WURDE ENTFERNT--

Gruess

Pete
Moderatoren: Tribal6, RePao, Dragonlord, Chris Hoefliger, pascale, adiheutschi.ch
Powered by Kunena Forum

Joomla! Verband Schweiz - Mitglied werden