Joomla! Forum Schweiz wird Teil der D-A-CH Community

Nach vielen Jahren als zentrale Anlaufstelle für Fragen rund um Joomla! in der Schweiz wird das Joomla! Forum Schweiz künftig als Archiv weitergeführt.

Die Joomla!-Communities aus Deutschland, Österreich und der Schweiz arbeiten heute enger denn je zusammen. Deshalb bündeln wir künftig auch den deutschsprachigen Support und Austausch an einem gemeinsamen Ort im Joomla! D-A-CH Forum.

Für neue Fragen, Diskussionen und den Austausch mit der Community nutzt bitte ab sofort:

forum.joomla.de

Das Joomla! Forum Schweiz bleibt weiterhin bestehen und wird als Archiv im Lesemodus erhalten. Die vielen Beiträge, Lösungen und Erfahrungen aus den vergangenen Jahren bleiben damit weiterhin zugänglich und über die Suche auffindbar.

Wir bedanken uns herzlich bei allen Mitgliedern, Moderatoren und Helfern, die das Schweizer Joomla! Forum über viele Jahre mit ihrem Wissen und ihrem Engagement geprägt haben.

Wir sehen uns im Joomla! D-A-CH Forum!

Akeeba Datenbank-Backup kann nicht über phpMyAdmin importiert werden

Mehr
04 Feb. 2022 16:33 #49968 von crimle
Seit längerer Zeit nutze ich Akeeba Backup. Vor jeder Installation einer Aktualisierung erstelle ich über das entsprechende Icon ein One-click backup. In der Profil-Konfiguration verwende ich dafür die Einstellung «Main site database only (SQL file)».

Nun hatte ich den (seltenen) Fall, dass ich eine Datenbank wiederherstellen wollte. Leider musste ich feststellen, dass die von Akeeba Backup erzeugte Datenbank nicht über phpMyAdmin importiert werden konnte! Es erscheint diese Fehlermeldung:


Was die Sache auch nicht besser macht: im Hintergrund wurden viele (die meisten?) Tabellen korrekt importiert. Ja, die auf diese Weise wiederhergestellte Webseite funktioniert sogar. Aber bei vielen Aktionen im Back-End erscheinen ganz neue Fehlermeldungen. Sie lassen den Schluss zu, dass mit der Datenbank etwas nicht stimmt.

Selbstverständlich habe ich in der Systemsteuerung den Datenbankstatus überprüft. Er wurde auch tatsächlich als fehlerhaft angezeigt. Und ja: ich habe die Datenbankreparatur durchgeführt. Dann wurde «Keine Probleme» angezeigt. Aber die zahlreichen Fehlermeldungen im Back-End sind geblieben.

Kann es sein, dass ein mittels Akkeeba erstelltes Datenbank-Backup nur über Akeeba wiederhergestellt werden kann? Wenn ja: wie?

Danke und Gruss
Christof
Mehr
04 Feb. 2022 18:37 #49969 von Chris Hoefliger
Du hast aber in der Datenbank schon vorher alle Tabellen gelöscht? Oder in eine leere db importiert? Bei mir läuft letzteres eigentlich klaglos.

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Mehr
04 Feb. 2022 18:41 #49970 von crimle
Jaja, die Datenbank war beim Import völlig leer. «Klaglos» würde ich eigentlich erwarten. Meine Feststellung beunruhigt mich etwas. Ich hab's übrigens mehrmals versucht; die Fehlermeldung war immer die gleiche. Vielleicht versuche ich's bei einer anderen Webseite auch noch.
Mehr
04 Feb. 2022 19:02 - 04 Feb. 2022 19:04 #49971 von Chris Hoefliger
Also ich habe folgendes gemacht:
- In Akeeba ein neues Profil angelegt, das nur die db sichert, sonst nichts
- dann mit diesem Profil einen Backup gezogen. Ergebnis: 1 SQL File, unkomprimmiert
- eine neue db angelegt und das SQL File in diese importiert
- bei der Seite die configuration.php geändert, sodass sie auf die neue db zeigt
- die Seite aufgerufen -> läuft
- die Administration aufgerufen -> läuft, keine db-Fehler
 

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Mehr
06 Feb. 2022 15:22 #49972 von crimle
Ich hab's jetzt auf einer anderen Webseite nochmals versucht. Beruhigende Erkenntnis: das mit Akeeba erstellte Backup wurde hier ohne Fehlermeldung importiert. Im Back-End erscheinen keine Fehlermeldungen. Das hilft zwar für meine ursprünglich beschriebene Webseite nicht, aber ich gehe jetzt mal davon aus, dass das ein Einzelfall ist. Ich werde aber dranbleiben, denn gemäss Murphy müsste ich demnächst mit besagter Webseite ein Problem haben... :-)

Detail am Rande:
Mir fällt auf, dass die mit Akeeba-Backup erzeugte SQL-Datei wesentlich kleiner ist als die mit phpMyAdmin exportierte:

Datei mit Akeeba-Backup erzeugt: 1718 KB
Datei mit phpMyAdmin exportiert: 2287 KB
Mehr
06 Feb. 2022 15:48 #49973 von crimle
Neue Erkenntnisse:
(Tests mit zwei anderen Webseiten durchgeführt)

Joomla 3 Webseite mit Akeeba Backup Core 8.0.15 (2022-01-04)
Datenbank-Import ohne Fehlermeldung.

Joomla 4 Webseite mit Akeeba Backup CORE for Joomla!™ 9.0.11 (2022-01-04)
Datenbank-Import erneut mit Fehlermeldung!
Im Back-End treten allerdings keine Fehler mehr auf. Die Webseite scheint trotz der SQL-Import-Fehlermeldung zu funktionieren.

Ich kopiere mal die Fehlermeldung im Klartext hier hinein, damit sie besser lesbar ist:

FehlerStatische Analyse:14 Fehler wurden während der Analyse gefunden. 

  1. Unerwarteter Statement-Anfang. (near "ABDB" at position 3)
  2. Unerwartetes Zeichen. (near "`id`" at position 42)
  3. Unerwarteter Statement-Anfang. (near "`id`" at position 42)
  4. Unerwarteter Statement-Anfang. (near "`parent_id`" at position 47)
  5. Unerwarteter Statement-Anfang. (near "`lft`" at position 59)
  6. Unerwarteter Statement-Anfang. (near "`rgt`" at position 65)
  7. Unerwarteter Statement-Anfang. (near "`level`" at position 71)
  8. Unerwarteter Statement-Anfang. (near "`path`" at position 79)
  9. Unerwarteter Statement-Anfang. (near "`title`" at position 86)
  10. Unerwarteter Statement-Anfang. (near "`alias`" at position 94)
  11. Unerwarteter Statement-Anfang. (near "`state`" at position 102)
  12. Unerwarteter Statement-Anfang. (near "`access`" at position 110)
  13. Unerwarteter Statement-Anfang. (near "`language`" at position 119)
  14. Unerkannte Statement-Typ. (near "VALUES" at position 131)
 SQL-Befehl: Kopieren /**ABDB**/INSERT INTO #__finder_taxonomy (`id`,`parent_id`,`lft`,`rgt`,`level`,`path`,`title`,`alias`,`state`,`access`,`language`) VALUES ('1', '0', '0', '1', '0', '', 'ROOT', 'root', '1', '1', '*')MySQL meldet:
[img
Code:
#1064 - Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei '(`id`,`parent_id`,`lft`,`rgt`,`level`,`path`,`title`,`alias`,`state`,`access`...' in Zeile 2

Ich denke, der Fehler betrifft «nur» den Such-Index. Es ist ja der SQL-Befehl
Code:
INSERT INTO #__finder_taxonomy
welcher einen Syntax-Fehler aufweist.

Ich spiele mit dem Gedanken, dies dem Akeeba-Support zu melden. Aber wenn ich der einzige mit diesem Problem bin, dann lasse ich es vielleicht bleiben.
Mehr
07 Feb. 2022 10:30 #49976 von Chris Hoefliger
Gratuliere, du hast einen fehler gefunden in Akeeba Backup. Ich habe das ursprünglich mit einer 3er Seite versucht, da ist alles durchgelaufen, vielleich auch, weil der Finder nicht aktiv war. Dem bin ich nicht nachgegangen. Die Sache ist, dass der SQL Export in AB 9 einen Fehler hat. Wenn man das SQL File ansieht, sieht man dasdada:
 
Was natürlich klar nicht geht. Alle Tabellen sind inklusive Präfix im exportierten SQL File. Alle, ausser der finder_taxonimy.
Ich habe mir erlaubt, das Nicholas zu melden.

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Folgende Benutzer bedankten sich: crimle
Mehr
07 Feb. 2022 15:43 #49977 von Chris Hoefliger
Also, ich hab Antwort bekommen. Es ist tatsächlich ein Bug - genauer gesagt zwei. Morgen soll eh eine neue Version veröffentlicht werden, die wird den Bugfix bereits enthalten.
Kann hier nachgelesen werden:
www.akeeba.com/support/akeeba-backup-3x/...m-akeeba-backup.html

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.
Folgende Benutzer bedankten sich: crimle, patrick, MartinKopp
Moderatoren: Chris Hoefliger, Tribal6, RePao, Dragonlord, pascale, adiheutschi.ch
Powered by Kunena Forum

Joomla! Verband Schweiz - Mitglied werden