Beitrag auf Startseite eingezogen?

  • SHIVA
  • Autor
  • Besucher
  • Besucher
03 Dez. 2010 20:59 #27614 von SHIVA
Beitrag auf Startseite eingezogen? wurde erstellt von SHIVA
Neuerdings wird der unterste Beitrag in der rechte Spalte meiner Startseite eingezogen. Ich habe bisher verschiedene Beiträge deaktiviert, in der Annahme einer sei im Layout zu breit, das funktioniert jedoch nicht. Da ich die letzten Wochen nichts am CSS des Templates verändert habe, muss das Problem im Joomla selbst liegen. Hat jemand eine Ahnung was da los sein könnte?

Ich arbeite mit Joomla 1.5.22, das Template wurde ursprüngich in Artisteer gemacht.

Hier noch der Link: --ALTER LINK WURDE ENTFERNT--

Vielen Dank für eure Hilfe

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
03 Dez. 2010 23:41 #27615 von Tribal6

das Template wurde ursprüngich in Artisteer gemacht.

Artist was? ;)

Ja, ja, ich weiss schon, Artisteer ist halt in Desinger-/Templaterkreisen verpöhnt, belächelt, auf der Ignorierliste, was auch immer.

Ich lehn mich jetzt mal einbisschen aus dem Fenster, da ich nicht unbedingt der CSS Fachmann hier bin, wohl aber einbisschen Firefox und Firebug bedienen kann. Und der sagt mir, dass alle Artikel mit einer Klasse Namens 'art-post-body ' umschlossen sind (Zeile 1154 [wow] im CSS deines Templates), u.a. mit einem 'padding: 10px'.

So wie es scheint, fehlt im Artikel rechts oben irgendwo ein schliessendes Div, also ein '</div>' so das diese Klasse sowohl den Artikel rechts oben als auch rechts unten umschliesst. Und da der Artikel rechts unten korrekterweise auch eine solche Klasse hat, also somit zweimal damit umschlossen ist, greift das 'padding: 10px' beim unteren Artikel auch zweimal, also insgsamt 20px padding für diesen Artikel und nur 10px für die anderen.

Dani? Patrick? Stimmt doch so, oder? Bitte einfach fröhlich (und bitte auch wohlwollend ;) ) reinquatschen, falls das Quark ist.

Thirsty Friday
Roger


Tue das was du kannst, mit dem was du hast, da wo du bist

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
04 Dez. 2010 07:39 #27616 von patrick
Roger, deine Erklärung dürfte stimmen:
--ALTER LINK WURDE ENTFERNT--

Weit nach unten scrollen, dann steht da:

# Error Line 350, Column 5: end tag for "div" omitted, but OMITTAG NO was specified
You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".
# Info Line 288, Column 1: start tag was here
<div class="art-post">


Artisteer: Ist bei mir nicht verpöhnt, auch nicht belächelt. Aber mehr oder weniger auf der Ignorierliste. Kommt halt immer darauf an, ob ich einen Haufen Zeit habe oder nicht, mich durch die sinnlos grosse Menge an Code zu wühlen... ;)

SHIVA schrieb: Da ich die letzten Wochen nichts am CSS des Templates verändert habe

Jetzt könnte ich mal wieder den Link zur Seite mit den Infos über die Heinzelmännchen posten :D

Schönes Weekend!

InitCom: Webagentur für Webdesign // CMS Joomla! // PrestaShop

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • SHIVA
  • Autor
  • Besucher
  • Besucher
08 Dez. 2010 20:53 #27661 von SHIVA
Vielen Dank euch Beiden

anhand eurer Analyse des Quellcodes der Startseite kann ich nachvollziehen was das Problem ist, nur hab ich keine Ahnung wie ich das beheben kann. Die Kollumnen steure ich doch über Joomla, soweit ich weiss habe ich via CSS kein Zugriff darauf. ??? ? ? Das Thema Artisteer lassen wir hier mal links liegen:-\

Hier noch der Code zum art post body:

/* begin Box, Post */
.art-post
{
position: relative;
z-index: 0;
margin: 0 auto;
min-width: 1px;
min-height: 1px;
}

.art-post-body
{
position: relative;
z-index: 1;
padding: 10px;
}


.art-post
{
margin: 7px;
}

a img
{
border: 0;
}

.art-article img, img.art-article
{
border: solid 1px #0F507B;
margin: 3px;
}

.art-metadata-icons img
{
border: none;
vertical-align: middle;
margin: 2px;
}

.art-article table, table.art-article
{
border-collapse: collapse;
margin: 1px;
width: auto;
}

.art-article table, table.art-article .art-article tr, .art-article th, .art-article td
{
background-color: Transparent;
}

.art-article th, .art-article td
{
padding: 2px;
border: solid 1px #7095A9;
vertical-align: top;
text-align: left;
}

.art-article th
{
text-align: center;
vertical-align: middle;
padding: 7px;
}

pre
{
overflow: auto;
padding: 0.1em;
}

/* end Box, Post */

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
09 Dez. 2010 05:53 #27665 von patrick
Die Template-Datei index.php und auch die CSS-Dateien kannst du über das CMS bearbeiten:
Erweiterungen ==> Templates ==> Template anklicken ==> oben rechts hast du dann HTML bearbeiten und CSS bearbeiten.

Die andere Möglichkeit ist, dass du dir die Dateien mit FTP holst, bearbeitest und wieder auf den Server kopierst.

InitCom: Webagentur für Webdesign // CMS Joomla! // PrestaShop

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • SHIVA
  • Autor
  • Besucher
  • Besucher
09 Dez. 2010 14:10 #27668 von SHIVA
Danke Patrick, aber soweit bin ich schon gekommen :D Ich weiss einfach nicht wo die Heinzelmännchen etwas verändert haben. Ich habe mittlerweilen dass Template CSS mit einer Sicherung vom Juni überschrieben, damals bestand der Bug noch nicht. Hat leider nichts genützt. Also muss der Fehler im php liegen und davon verstehe ich absolut nichts.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
09 Dez. 2010 17:58 #27674 von patrick

SHIVA schrieb: Ich habe mittlerweilen dass Template CSS mit einer Sicherung vom Juni überschrieben, damals bestand der Bug noch nicht. Hat leider nichts genützt. Also muss der Fehler im php liegen und davon verstehe ich absolut nichts.

Dann könnte der Fehler aber auch im Beitrag selbst liegen. ;)

Hast du die Problematik immer, egal welcher Beitrag zuletzt (und somit eingerückt) angezeigt wird? Oder nur bei bestimmten Beiträgen?

InitCom: Webagentur für Webdesign // CMS Joomla! // PrestaShop

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • SHIVA
  • Autor
  • Besucher
  • Besucher
10 Dez. 2010 08:17 #27683 von SHIVA
Also ich habe schon jeden Beitrag einmal inaktiviert, es bleibt jedoch dabei, dass jeweils der 2. Letzte, resp der unterste rechts eingezogen ist.

Wenn ich die Spalten auf 1 reduziere ist der 4. Beitrag von oben eingezogen.

Wenn ich von den 6 Beiträgen 2 inaktiviere dann ist der letzte (unterste links) eingezogen.

Es ist zum "Haarölseichen"

Vielen Danken für dein Engagement

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
10 Dez. 2010 13:40 #27686 von jimbo
Ich würde meinen, dass Artisteer das padding auf einen "unglücklichen" Container legt. Siehst Du dir den Quellcode an, wirst Du sehen, dass alle Beiträge nach dem gleichen Muster ausgegeben werden, ausser der letzte:
Code:
<div class="art-post"> <div class="art-post-body"> <!-- das ist der korrekt angezeigte Beitrag <div class="art-post-inner"> <h2 class="art-postheader">Erkältungen</h2> <div class="art-postcontent"> ... </div> <div class="cleared"></div> </div> <div class="cleared"></div> </div> <div class="art-post"> <!-- dieser Container erscheint zusätzlich mit 10px padding <div class="art-post-body"> <!-- das ist der falsch angezeigte Beitrag <div class="art-post-inner"> <h2 class="art-postheader">Medikamenten-News</h2> <div class="art-postcontent"> ... </div> <div class="cleared"></div> </div> </div> </div> </div>

Wie man das beheben kann? Wie in Artisteer leider immer: zig CSS-Klassen umschreiben und hoffen dass es anschliessend noch mehr oder weniger funktioniert. Allenfalls mal im deutschen Artisteer-Forum nachfragen, vielleicht kennt man dort einen Trick.

Gruss Dany (Jimbo)
Kein Support per PN.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Chris Hoefliger
  • Offline
  • Platin Mitglied
  • Platin Mitglied
Mehr
10 Dez. 2010 15:55 #27688 von Chris Hoefliger
Chris Hoefliger antwortete auf Re: Beitrag auf Startseite eingezogen?
Also, ich hab schon mal einene eindeutigen und reprodizierbaren Fehler in Artisteer beim Hersteller gemeldet, welcher dann einen Link auf die Seite mit dem Fehler haben wollte. Draufhin haben sie tatsächlich zugegeben, dass hier ein Bug vorliegt, und - man denke - haben selbigen im nächsten Update behoben (ohne Eintrag im Changelog allerdings)...

Joomla! 3: Professionelle Webentwicklung von David Jardin und Elisa Foltyn - das Standardwerk zu Joomla! 3
Wer nicht über den Anstand verfügt, ein kleines "Thänx" auszusprechen, muss sich nicht wundern, künftig ignoriert zu werden!
Kein Support via PM oder Mail. Entsprechende Anfragen werden ignoriert.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: Tribal6RePaoDragonlordChris Hoefligerpascaleadiheutschi.ch
Powered by Kunena Forum

Joomla! Verband Schweiz - Mitglied werden